| Age | Commit message (Collapse) | Author | Files | Lines |
|
Per our PTG resolution [1] and general OpenStack resolution [2], lower-constraints
are not worth the extra work and confusion they introduce.
This patch drops them along with all mentions.
[1] http://lists.openstack.org/pipermail/openstack-discuss/2020-October/018445.html
[2] http://lists.openstack.org/pipermail/openstack-discuss/2020-December/019521.html
Change-Id: I58807c27fd20c7269019e26e8b507744d35325f3
|
|
Change-Id: Ie112466da402fc127b61cefdef4c1180e5ce1210
Story: 2007865
Task: 40199
Closes-Bug: #1886298
|
|
the six unused anywhere, clean it up from lower-constraints.txt
Change-Id: I15474459e6321aa3570ce279c7d1aa1ed29f19c0
|
|
The mox3 repo is being retired.
Change-Id: I8e1188257f0025f2e833aa7a1f414f4165f80092
|
|
Removes and/or replaces all mentions of py27.
Cleans up obsolete requirements and their lower-constraints.
Change-Id: Id43f1bbd6a454832ab8dbf003a058403f6b34b5d
|
|
|
|
Now that py2 is gone, oslotest dropped dependency on mock and will
soon affect Ussuri CI [1], let's use unittest.mock built in py3.
This also fixes py38 jobs and proactively prevents py36 and py37
failing due to [1]. This is because we never included mock in
test-requirements (but in lower-constraints where it does not
really belong at all) and instead relied on oslotest to bring
it in.
[1] https://review.opendev.org/716322
Change-Id: Iceedcc7ad0d087414f6f94dfc0235fda4754be63
|
|
The repo is Python 3 now, so update hacking to version 3.0 which
supports Python 3.
Fix problems found by updated hacking version.
Update local hacking checks for new flake8.
Remove hacking and friends from lower-constraints, they are not
needed in installations.
Change-Id: I67e5ca24c550163c218fb06692de0b7c528d8318
|
|
The is one of community goals that each project should produce a
single PDF file. The pdf should be in the output of openstack-tox-docs
job.
TeX packages are required to build PDF locally, following is
recommended:
* inkscape
* texlive-latex-base
* texlive-latex-extra
* texlive-fonts-recommended
More about the goal:
https://governance.openstack.org/tc/goals/train/pdf-doc-generation.html
https://etherpad.openstack.org/p/train-pdf-support-goal
https://etherpad.openstack.org/p/pdf-goal-train-common-problems
Change-Id: Ia0f8b73bcbda6295319f5c8de1aa02a40844207b
|
|
Ubuntu Bionic updated OpenSSL package to new release:
from 1.1.0 to 1.1.1
It caused cryptography in version from lower-constraints
to fail to build in Zuul.
Additionally, constrained cryptography version did not
match the requirement for constrained PyOpenSSL.
This commit bumps the version to the minimum required
by constrained PyOpenSSL.
It works because manylinux1 (binary) wheel exists.
This version agrees also with upper-constraints for Queens.
Dependency on cryptography is removed as it is not used directly
by kolla (and requirements checker requires lower-constraints
matching version - let's not create an illusion of usage).
Change-Id: I8ae19f212049cae5dfb4e8dd6ec6cd14a8c46e0e
Signed-off-by: Radosław Piliszek <radoslaw.piliszek@gmail.com>
|
|
Multiple fixes to fix multiple problems.
1. Bump setuptools requirement to 21.0.0
The 16.0.0 requirement breaks the lower-constraints job on Ubuntu
bionic. We see the following error:
AttributeError: module 'importlib._bootstrap' has no attribute 'SourceFileLoader'
2. ubuntu-binary horizon image needs to use python3 for django
manage.py
3. ubuntu-binary nova-placement-api image needs to use python3 for
apache mod wsgi.
4. nova-libvirt needs exact qemu dependencies due to packaging change
5. OracleLinux repos definition was changed in official image.
6. Fetch InfluxDB gpg key for Ubuntu base image from influx server.
Change-Id: Ic797d41f53a5f146d112619f1683cbfbf3a85dc2
|
|
According to Openstack summit session [1],
stestr is maintained project to which all Openstack projects should migrate.
Let's switch to stestr as other projects have already moved to it.
[1] https://etherpad.openstack.org/p/YVR-python-pti
Change-Id: I27308a2435a4dca572d736f56a02b0bbc8563981
|
|
|
|
oslo.config>=5.2.0 which is a dependency of kolla
requires rfc3986>=1.2.0
Change-Id: I89708b8cba260d5d49ad6a7925eae7416a9f047f
|
|
Older hacking version depends on pep8, but pep8 module is replaced
by pycodestyle. This is already resolved by updating hacking
version in https://review.openstack.org/#/c/627148/
pep8 is dropped, so no longer require in lower-constraints.txt.
Change-Id: I4c834e11515c9384975801e1b710fa554c726c0d
|
|
It should be updated in https://review.openstack.org/#/c/627148/
but missing, this ps to update it.
Change-Id: Idea1cc84d2e551d160207d44751a30f6232e0cd1
Closes-Bug: #1810530
|
|
lower constraints list do not match the local requirements.
This commit is to update the same.
please follow:
http://lists.openstack.org/pipermail/openstack-dev/2018-April/129056.html
Change-Id: Ic617e22e0e1118cb40e471608b0250bf77b2a26c
|
|
Create a tox environment for running the unit tests against the lower
bounds of the dependencies.
Create a lower-constraints.txt to be used to enforce the lower bounds
in those tests.
Add openstack-tox-lower-constraints job to the zuul configuration.
See http://lists.openstack.org/pipermail/openstack-dev/2018-March/128352.html
for more details.
Change-Id: I5753b175264c074ff722b47293c65063f0187ffe
Depends-On: https://review.openstack.org/555034
Signed-off-by: Doug Hellmann <doug@doughellmann.com>
|